Comodo/ Sectigo SSL Maintenance
Incident Report for Enom
Resolved
Setting the incident to 'resolved'. Thanks for sitting through this one!
Posted Jan 15, 2019 - 14:19 PST
Identified
Our Comodo/ Sectigo SSL services are undergoing maintenance. Certificate configuration attempts may be interrupted. Purchasing new Comodo SSL products is not affected.
Posted Jan 15, 2019 - 12:48 PST
This incident affected: SSL Certificates.