Hosted email

Incident Report for Enom

Resolved

This incident has been resolved.
Posted Nov 21, 2019 - 07:44 PST

Monitoring

We have implemented a fix so hosted email users should now be able to access their Enom emails through IMAP on their mail clients. We will be monitoring the case to make sure that there are no further issues. Thank you for your patience with this case.
Posted Nov 21, 2019 - 06:52 PST

Identified

The issue has been identified by our dev team, and we are working on implementing a fix. We appreciate your continued patience with this case. Please continue to access your webmail through mail.enom.com until this issue is resolved.
Posted Nov 21, 2019 - 06:28 PST

Investigating

We are currently investigating reports of some hosted email users being unable to connect to their email accounts through IMAP (e.g. email clients, mobile devices). We'll update as soon as we know more.

For a temporary workaround, access your email through webmail at mail.enom.com.
Posted Nov 21, 2019 - 05:17 PST
This incident affected: Basic Email Service.