CentralNIC Registry
Incident Report for Enom
Resolved
Connections to CentralNic have been restored. Services are functioning as they should.
Posted about 1 month ago. May 14, 2019 - 06:40 PDT
Identified
The registry has confirmed that there is an issue on their end that needs to be addressed. Work continues to resolve the issue.
Posted about 1 month ago. May 14, 2019 - 05:33 PDT
Investigating
We are currently having connection issues with the CentralNic registry. The registry might be experiencing a temporary outage or undergoing unexpected maintenance.

Our operations team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of CentralNic domains. Existing domains will continue to resolve normally.

Please see http://enom.help/chart for a list of affected domains
Posted about 1 month ago. May 14, 2019 - 04:41 PDT
This incident affected: Domain Services (Other gTLDs).