.Kiwi Registry Connections
Incident Report for Enom
Resolved
We are happy to report that the connection has been restored to the .Kiwi Registry. All pending orders can now be processed.
Posted 11 days ago. Aug 07, 2019 - 15:41 PDT
Investigating
We are currently experiencing connection issues with the .Kiwi registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .Kiwi domains. Existing domains will continue to resolve normally.
Posted 11 days ago. Aug 07, 2019 - 14:41 PDT
This incident affected: Domain Services (Other ccTLDs).