.ASIA/.ME/.XXX/.BZ registry connection
Incident Report for Enom
Resolved
Our connection to the Afilias has been restored.

Thank you for your patience.
Posted Jul 27, 2020 - 19:59 PDT
Update
We are currently experiencing connection issues with the Afilias registry.

Users will experience difficulties to lookup .xxx/.asia/.me/.bz TLD's; renewals and registrations will also be unavailable at this time.

We will continue to investigate and provide further information as it becomes available.
Posted Jul 27, 2020 - 19:20 PDT
Investigating
Degradation of service
Posted Jul 27, 2020 - 18:50 PDT
This incident affected: Domain Services (Core ccTLDs).