Plesk control panel on ehost-services215.com
Incident Report for Enom
Resolved
We have restored Plesk control panel access on ehost-services215.com. Sorry about that!
Posted 2 months ago. Feb 07, 2019 - 07:35 PST
Investigating
Signing in to a Plesk control panel hosted on ehost-services215.com will result in an error right now. We are trying to find out what's gone wrong.

Customer hosted websites are still resolving, this is limited to Plesk control panel access.
Posted 2 months ago. Feb 07, 2019 - 06:34 PST
This incident affected: Web Hosting Service.