Account Password Reset Delays
Incident Report for Enom
Resolved
This incident has been resolved.
Posted May 20, 2020 - 10:44 PDT
Monitoring
Our operations team was able to identify the issue and implement a fix. Password Reset Emails should no longer be delayed. We will continue to monitor for further reports.
Posted May 20, 2020 - 08:07 PDT
Investigating
We are investing reports of account password reset emails not being delivered. At this time users will be unable to reset their account password.
Posted May 20, 2020 - 07:41 PDT