Support Center help requests
Incident Report for Enom
Resolved
Zendesk has resolved the issue on their end. Users may now submit help requests through the Support Center.
Posted Aug 22, 2018 - 00:03 PDT
Identified
Zendesk has confirmed that the issue is on their end, and it affects the "Guide" system in Helpdesk. This includes the ability to submit requests. We are monitoring Zendesk's progress on addressing this issue. We will update you as soon as we have more inforamtion.
Posted Aug 21, 2018 - 23:11 PDT
Investigating
We are aware of an issue affecting the ability to submit verified help requests from within Enom accounts.

If you have an urgent issue, you can contact us via chat or phone.

We have noted it is possible to submit requests using a shorter subject line, if you have a request fail to submit and you have come to an error page, you can go back and shorten the subject to submit.

We are investigating this and will update when we have more information.
Posted Aug 21, 2018 - 21:59 PDT
This incident affected: Customer Support.