Payment Processing Outage
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 13:16 PST
Monitoring
Our payment processing system is back online. Transactions on accounts should be going through. We will keep monitoring to make sure there are no further issues.
Posted Nov 17, 2020 - 12:02 PST
Investigating
We are currently seeing an interruption in payment processing at Enom. During this time any orders that you may try to process in your account may fail. Our dev team is working to get this fixed as soon as possible. We appreciate your patience in this case.
Posted Nov 17, 2020 - 09:56 PST
This incident affected: Enom.com (Domain Purchase).